<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.allatsea.net/xmlrpc.php" />
<title>Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta - ALL AT SEA</title>
<meta property="og:title" content="Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta - ALL AT SEA" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Hurricanes couldn’t stop the 25th anniversary of the St. Croix International Regatta. Originally sch" />
<meta property="og:url" content="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/" />
<meta property="og:site_name" content="ALL AT SEA" />
<meta property="og:image" content="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112-660x330.jpg" />
<script type="d0048e28acfa355d3e3f70ba-">window._wca = window._wca || [];</script>

<meta name="description" content="Hurricanes couldn’t stop the 25th anniversary of the St. Croix International Regatta. Originally scheduled for November 2017, the two-in-one event kicked o" />
<link rel="canonical" href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/" />
<link rel="publisher" href="https://plus.google.com/+AllatseaNet" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta - ALL AT SEA" />
<meta property="og:description" content="Hurricanes couldn’t stop the 25th anniversary of the St. Croix International Regatta. Originally scheduled for November 2017, the two-in-one event kicked o" />
<meta property="og:url" content="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/" />
<meta property="og:site_name" content="ALL AT SEA" />
<meta property="article:publisher" content="https://www.facebook.com/ALLATSEACaribbean" />
<meta property="article:tag" content="St. Croix International Regatta" />
<meta property="article:section" content="Sail" />
<meta property="article:published_time" content="2018-05-22T22:04:18+00:00" />
<meta property="fb:admins" content="553769312" />
<meta property="og:image" content="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112.jpg" />
<meta property="og:image:secure_url" content="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112.jpg" />
<meta property="og:image:width" content="1224" />
<meta property="og:image:height" content="968" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Hurricanes couldn’t stop the 25th anniversary of the St. Croix International Regatta. Originally scheduled for November 2017, the two-in-one event kicked o" />
<meta name="twitter:title" content="Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta - ALL AT SEA" />
<meta name="twitter:site" content="@allatseacarib" />
<meta name="twitter:image" content="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112.jpg" />
<meta name="twitter:creator" content="@allatseacarib" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.allatsea.net\/","name":"ALL AT SEA - Caribbean Sailing, Boating, Fishing and Yachting News","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.allatsea.net\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.allatsea.net\/hurricanes-couldnt-stop-25th-saint-croix-international-regatta\/","sameAs":["https:\/\/www.facebook.com\/ALLATSEACaribbean","https:\/\/plus.google.com\/+AllatseaNet","https:\/\/twitter.com\/allatseacarib"],"@id":"#organization","name":"ALL AT SEA","logo":"http:\/\/www.allatsea.net\/wp-content\/uploads\/2014\/01\/AAS-Featured-Image.jpg"}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//ssl.google-analytics.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="ALL AT SEA &raquo; Feed" href="https://www.allatsea.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="ALL AT SEA &raquo; Comments Feed" href="https://www.allatsea.net/comments/feed/" />
<link rel="alternate" type="text/calendar" title="ALL AT SEA &raquo; iCal Feed" href="https://www.allatsea.net/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="ALL AT SEA &raquo; Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta Comments Feed" href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/feed/" />
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.allatsea.net\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tie-insta-style-css' href='https://www.allatsea.net/wp-content/plugins/instanow/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.allatsea.net/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-buttons-style-css' href='https://www.allatsea.net/wp-content/plugins/taqyeem-buttons/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-style-css' href='https://www.allatsea.net/wp-content/plugins/taqyeem/style.css' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='tie-style-css' href='https://www.allatsea.net/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-woocommerce-css' href='https://www.allatsea.net/wp-content/themes/sahifa/css/woocommerce.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css' href='https://www.allatsea.net/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css' href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css' href='https://www.allatsea.net/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimp-top-bar-css' href='https://www.allatsea.net/wp-content/plugins/mailchimp-top-bar/assets/css/bar.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.allatsea.net/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var tie_insta = {"ajaxurl":"https:\/\/www.allatsea.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-includes/js/jquery/jquery.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/taqyeem/js/tie.js'></script>
<link rel='https://api.w.org/' href='https://www.allatsea.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.allatsea.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.allatsea.net/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/p7rGnm-FD2' />
<link rel="alternate" type="application/json+oembed" href="https://www.allatsea.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.allatsea.net%2Fhurricanes-couldnt-stop-25th-saint-croix-international-regatta%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.allatsea.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.allatsea.net%2Fhurricanes-couldnt-stop-25th-saint-croix-international-regatta%2F&#038;format=xml" />
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var taqyeem = {"ajaxurl":"https://www.allatsea.net/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};
/* ]]> */
</script>
<style type="text/css" media="screen">

</style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.allatsea.net"><link rel="https://theeventscalendar.com/" href="https://www.allatsea.net/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://www.allatsea.net/wp-content/uploads/2012/11/favicon.ico" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://www.allatsea.net/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://www.allatsea.net/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.allatsea.net/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.allatsea.net/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.allatsea.net/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.allatsea.net/wp-content/uploads/2014/01/apple-ipad-retina-144.jpg" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.allatsea.net/wp-content/uploads/2014/01/apple-iphone-icon-120.jpg" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.allatsea.net/wp-content/uploads/2014/01/apple-ipad-72.jpg" />
<link rel="apple-touch-icon-precomposed" href="https://www.allatsea.net/wp-content/uploads/2014/01/iphone-icon-57.jpg" />
<meta property="fb:pages" content="10150138295065416" />

<script type="d0048e28acfa355d3e3f70ba-text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
<!--
googletag.cmd.push(function() {
googletag.defineSlot('/9424366/AAS-Lft-Col-Med-Rect', [300, 250], 'div-gpt-ad-1404487490641-0').addService(googletag.pubads());
googletag.defineSlot('/9424366/CB_Btm_Full_Bnr_468x60', [468, 60], 'div-gpt-ad-1400683834746-0').addService(googletag.pubads());
googletag.defineSlot('/9424366/CB_Half_Page_300x600', [300, 600], 'div-gpt-ad-1400683834746-1').addService(googletag.pubads());
googletag.defineSlot('/9424366/Logo-Leaderboard-728x90', [728, 90], 'div-gpt-ad-1400683834746-10').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
// -->
</script>


<style>
    .cse .gsc-search-button input.gsc-search-button-v2,
    input.gsc-search-button-v2 {
        height: 26px !important;
        margin-top: 0 !important;
        min-width: 13px !important;
        padding: 5px 26px !important;
        width: 68px !important;
    }
</style>

<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #7b77ff;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#7b77ff;
}

::-webkit-scrollbar-thumb{
	background-color:#7b77ff !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #7b77ff;
}

.search-block:after {
	border-right-color:#7b77ff;
}

body.rtl .search-block:after {
	border-left-color:#7b77ff;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #7b77ff;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #7b77ff;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #7b77ff;
	border-color: #7b77ff;
}

#order_review,
#order_review_heading {
	border-color: #7b77ff;
}


.background-cover{
	background-color:#ffffff !important;
	background-image : url('') !important;
	filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(src='',sizingMethod='scale') !important;
	-ms-filter: "progid:DXImageTransform.Microsoft.AlphaImageLoader(src='',sizingMethod='scale')" !important;
}
	
body.single .post .entry a, body.page .post .entry a {
	color: #5551d1;
	text-decoration: underline;
}
		
.ads_4x4{
	margin: 0px 0px;
	
}
.ads_4x4 div{
	height: 125px;
	width:125px;
	margin:5px 5px;
	background-color: #ddd;
	display:inline-block;
}

.ads_2x2{
	margin: 0px 20px 0px 0px;
	
}
.ads_2x2 div{
	height: 250px;
	width: 300px;
	margin:5px 5px;
	background-color: #fff;
	display:inline-block;
}
.data{					
	width:600px;
	padding-bottom:30px;
	padding-top:30px;
	margin: 10px 10px 10px 10px;
	border-bottom:0px solid #999;
	}
.data a{
	color:#666;
	text-decoration: underline;
	}
.data img{
	float:left;
	padding-right:20px;
	padding-bottom:5px;
	}@media only screen and (max-width: 767px) and (min-width: 480px){
	.ads-top, .ads-bottom, .home-ads, .ads-post{display: block !important;}
.ads-top img, .ads-bottom img, .home-ads img , .ads-post img {max-width: 100% !important; height: auto;}
}

@media only screen and (max-width: 479px) and (min-width: 320px){
	.ads-top, .ads-bottom, .home-ads, .ads-post{display: block !important;}
.ads-top img, .ads-bottom img, .home-ads img , .ads-post img {max-width: 100% !important; height: auto;}
}

</style>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.allatsea.net\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.allatsea.net\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<link rel="amphtml" href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/amp/"><style type="text/css">
.mctb-bar, .mctb-response, .mctb-close { background: #ffcc00 !important; }
.mctb-bar, .mctb-label, .mctb-close { color: #222222 !important; }
.mctb-button { background: #222222 !important; border-color: #222222 !important; }
.mctb-email:focus { outline-color: #222222 !important; }
.mctb-button { color: #ffffff !important; }
</style><link rel="icon" href="https://www.allatsea.net/wp-content/uploads/2016/04/cropped-site-icon-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.allatsea.net/wp-content/uploads/2016/04/cropped-site-icon-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.allatsea.net/wp-content/uploads/2016/04/cropped-site-icon-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.allatsea.net/wp-content/uploads/2016/04/cropped-site-icon-270x270.jpg" />
<script async src='https://stats.wp.com/s-201821.js' type="d0048e28acfa355d3e3f70ba-"></script>
</head>
<body id="top" class="post-template-default single single-post postid-160024 single-format-standard woocommerce-no-js tribe-no-js lazy-enabled">
<div class="wrapper-outer">
<div class="background-cover"></div>
<aside id="slide-out">
<div class="search-mobile">
<form method="get" id="searchform-mobile" action="https://www.allatsea.net/">
<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js" data-cf-nonce="d0048e28acfa355d3e3f70ba-"></script><input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}" />
</form>
</div>
<div class="social-icons">
<a class="ttip-none" title="Rss" href="https://feeds.feedburner.com/allatsea/iHcq" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/+AllatseaNet" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/ALLATSEACaribbean" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://www.twitter.com/allatseacarib" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Pinterest" href="https://pinterest.com/allatseamag/" target="_blank"><i class="fa fa-pinterest"></i></a>
</div>
<div id="mobile-menu"></div>
</aside>
<div id="wrapper" class="wide-layout">
<div class="inner-wrapper">
<header id="theme-header" class="theme-header">
<div id="top-nav" class="top-nav">
<div class="container">
<div class="top-menu"><ul id="menu-top-custom-menu" class="menu"><li id="menu-item-42225" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42225"><a href="http://www.yourislands.com">Your Islands Travel</a></li>
<li id="menu-item-42226" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42226"><a href="http://www.yachtessentials.com">YACHT Essentials</a></li>
</ul></div>
<div class="search-block">
<form method="get" id="searchform-header" action="https://www.allatsea.net/">
<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js" data-cf-nonce="d0048e28acfa355d3e3f70ba-"></script><input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}" />
</form>
</div>
<div class="social-icons">
<a class="ttip-none" title="Rss" href="https://feeds.feedburner.com/allatsea/iHcq" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/+AllatseaNet" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/ALLATSEACaribbean" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://www.twitter.com/allatseacarib" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Pinterest" href="https://pinterest.com/allatseamag/" target="_blank"><i class="fa fa-pinterest"></i></a>
</div>
</div>
</div>
<div class="header-content">
<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
<div class="logo" style=" margin-top:10px;">
<h2> <a title="ALL AT SEA" href="https://www.allatsea.net/">
<img src="https://www.allatsea.net/wp-content/uploads/2014/02/all-at-sea-logo.jpg" alt="ALL AT SEA" /><strong>ALL AT SEA Caribbean &amp; South Florida Boating Sailing Fishing and Charter</strong>
</a>
</h2> </div>
<div class="e3lan e3lan-top"> 
<div id='div-gpt-ad-1400683834746-10' style='width:728px; height:90px;'>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1400683834746-10'); });
</script>
</div> </div> <div class="clear"></div>
</div>
<nav id="main-nav" class="fixed-enabled">
<div class="container">
<div class="main-menu"><ul id="menu-top-navigation" class="menu"><li id="menu-item-5136" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5136"><a href="http://www.allatsea.net/">HOME</a></li>
<li id="menu-item-30515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30515"><a href="https://www.allatsea.net/charter/">Charter</a></li>
<li id="menu-item-14120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14120"><a href="https://www.allatsea.net/boat-2/">Boat</a></li>
<li id="menu-item-14121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14121"><a href="https://www.allatsea.net/cruise/">Cruise</a></li>
<li id="menu-item-14122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14122"><a href="https://www.allatsea.net/fish/">Fish</a>
<ul class="sub-menu menu-sub-content">
<li id="menu-item-14254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14254"><a href="https://www.allatsea.net/fish/inshore-fishing/">Inshore Fishing</a></li>
<li id="menu-item-14255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14255"><a href="https://www.allatsea.net/fish/offshore-fishing/">Offshore Fishing</a></li>
</ul>
</li>
<li id="menu-item-14123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14123"><a href="https://www.allatsea.net/live/">Life</a></li>
<li id="menu-item-14124" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14124"><a href="https://www.allatsea.net/sail/">Sail</a></li>
<li id="menu-item-25789" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25789"><a href="http://www.allatsea.net/events/">Calendar</a>
<ul class="sub-menu menu-sub-content">
<li id="menu-item-25787" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-25787"><a href="https://www.allatsea.net/events/category/boat-show/">Boat Show</a></li>
<li id="menu-item-25786" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-25786"><a href="https://www.allatsea.net/events/category/fishing-tournament/">Fishing Tournaments</a></li>
<li id="menu-item-25785" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-25785"><a href="https://www.allatsea.net/events/category/sailing-regatta/">Sailing Regattas</a></li>
<li id="menu-item-25788" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-25788"><a href="https://www.allatsea.net/events/category/poker-run/">Poker Run</a></li>
</ul>
</li>
<li id="menu-item-19770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19770"><a href="https://www.allatsea.net/shop/">Shop</a></li>
</ul></div> <a href="https://www.allatsea.net/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a>
</div>
</nav>
</header>
<div id="main-content" class="container sidebar-left">
<div class="content">
<div xmlns:v="http://rdf.data-vocabulary.org/#" id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.allatsea.net">Home</a></span> <span class="delimiter">&raquo;</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.allatsea.net/sail/">Sail</a></span> <span class="delimiter">&raquo;</span> <span class="current">Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta</span></div>
<article class="post-listing post-160024 post type-post status-publish format-standard has-post-thumbnail  category-sail category-st-croix tag-st-croix-international-regatta" id="the-post">
<div class="post-inner">
<h1 class="name post-title entry-title"><span itemprop="name">Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta</span></h1>
<p class="post-meta">
<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.allatsea.net/author/carol_bareuther/" title="">Carol_Bareuther </a></span>
<span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.allatsea.net/sail/" rel="category tag">Sail</a>, <a href="https://www.allatsea.net/caribbean/eastern/us-virgin-islands/st-croix/" rel="category tag">St. Croix, US Virgin Islands</a></span>
<span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/#respond">Leave a comment</a></span>
</p>
<div class="clear"></div>
<div class="entry">
<div class="share-post">
<span class="share-text">Share</span>
<script type="d0048e28acfa355d3e3f70ba-">
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 	'fbjssdk' );
		load('https://apis.google.com/js/plusone.js', 		'gplus1js');
		load('//platform.twitter.com/widgets.js', 			'tweetjs' );
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
<ul class="normal-social">
<li>
<div class="fb-like" data-href="https://wp.me/p7rGnm-FD2" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
</li>
<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://wp.me/p7rGnm-FD2" data-text="Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta" data-via="allatseacarib" data-lang="en">tweet</a></li>
<li style="width:80px;"><div class="g-plusone" data-size="medium" data-href="https://wp.me/p7rGnm-FD2"></div></li>
<li><script src="https://platform.linkedin.com/in.js" type="d0048e28acfa355d3e3f70ba-text/javascript"></script><script type="IN/Share" data-url="https://wp.me/p7rGnm-FD2" data-counter="right"></script></li>
</ul>
<div class="clear"></div>
</div> 
<figure id="attachment_160025" style="width: 600px" class="wp-caption aligncenter"><a href="http://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/lead-dsc_5553/" rel="attachment wp-att-160025"><img data-attachment-id="160025" data-permalink="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/lead-dsc_5553/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112.jpg" data-orig-size="1224,968" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Lead-DSC_5553" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112-600x475.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112-1024x810.jpg" class="wp-image-160025 size-medium" src="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112-600x475.jpg" alt="29ers – Those magnificent men and women on their flying trapeze … Crew Lake Sanford (lead boat) and Elyssa Franklin" width="600" height="475" srcset="https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112-600x475.jpg 600w, https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112-1024x810.jpg 1024w, https://www.allatsea.net/wp-content/uploads/2018/04/Lead-DSC_5553-e1524795766112.jpg 1224w" sizes="(max-width: 600px) 100vw, 600px" /></a><figcaption class="wp-caption-text">29ers – Those magnificent men and women on their flying trapeze … Crew Lake Sanford (lead boat) and Elyssa Franklin</figcaption></figure>
<p>Hurricanes couldn’t stop the 25th anniversary of the St. Croix International Regatta. Originally scheduled for November 2017, the two-in-one event kicked off with the one-day Captain Nick race to Christiansted Harbor and back to the host St. Croix Yacht Club on March 8 followed by the two-day silver jubilee regatta on March 9 and 10. Despite the date change, the Regatta hosted a highly competitive one-design Rhodes 19 class, held its reputation as a large multihull event and added a new class: 29ers.</p>
<p>The weekend’s win in the Rhodes 19s was a triumph of survival of the fittest for Chris Stanton and crew Joseph Noel, aboard the Rhodes 19, <i>Rhode Devil</i>. Blustery wind conditions on the first day of racing caused the class to suffer a series of breakdowns. Before the start of the first race, Beecher Higby’s <i>AVA</i> broke her boom. During the first race, <i>Up De Rhode</i>, with 16-year-old Rider Odom driving, damaged a chain plate. During the second race, Morgan Dale’s <i>Rhode Runner</i> broke its main halyard, leaving Stanton along with the husband and wife team of Chris and Deb Schreiber on <i>Chrys</i>, in a match race.</p>
<figure id="attachment_160027" style="width: 483px" class="wp-caption aligncenter"><img data-attachment-id="160027" data-permalink="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/3-img_4187/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807.jpg" data-orig-size="876,1089" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="3-IMG_4187" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807-483x600.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807-824x1024.jpg" class="size-medium wp-image-160027" src="https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807-483x600.jpg" alt="Chris Stanton – a whole lot of skipper with a whole lot of rum" width="483" height="600" srcset="https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807-483x600.jpg 483w, https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807-824x1024.jpg 824w, https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807-600x746.jpg 600w, https://www.allatsea.net/wp-content/uploads/2018/04/3-IMG_4187-e1524795890807.jpg 876w" sizes="(max-width: 483px) 100vw, 483px" /><figcaption class="wp-caption-text">Chris Stanton – a whole lot of skipper with a whole lot of rum</figcaption></figure>
<p>“While on a downwind leg behind <i>Chrys</i>, I was struggling to stabilize our boat in a 25-knot gust when my rudder broke off at the waterline and sent me into a violent Chinese gybe,” says Stanton. “This is when I found out it’s possible to capsize a keelboat and that my boat still has enough foam in the hull to keep it from sinking even with the decks awash. Leaving one boat to finish the race. That’s when the race committee said that we have had enough for the day. We were not the fastest boat on the course but our theory on keeping it simple kept us in front with the least number of mistakes.”</p>
<p><i>Rhode Devil</i>, repaired and back on the course the next day, having finished first in four out of five races, won Stanton his weight in St. Croix’s own Cruzan rum, the regatta’s signature prize.<span class="Apple-converted-space"> </span></p>
<p>A strong breeze and stiff competition in the form of a couple of Corsairs proved challenging for Joe San Martin, aboard his Teegull 23, <i>Piglet</i>, winner of the Multihull class.<span class="Apple-converted-space"> </span></p>
<figure id="attachment_160028" style="width: 600px" class="wp-caption aligncenter"><img data-attachment-id="160028" data-permalink="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/4-2018-03-10-20-35-27/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2018/04/4-2018-03-10-20.35.27-e1524795806279.jpg" data-orig-size="1210,847" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="4-2018-03-10-20.35.27" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2018/04/4-2018-03-10-20.35.27-e1524795806279-600x420.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2018/04/4-2018-03-10-20.35.27-e1524795806279-1024x717.jpg" class="size-medium wp-image-160028" src="https://www.allatsea.net/wp-content/uploads/2018/04/4-2018-03-10-20.35.27-e1524795806279-600x420.jpg" alt="Taylor Hasson and Steve Hardee qualified for the 2018 Youth Sailing World Championships in Texas" width="600" height="420" srcset="https://www.allatsea.net/wp-content/uploads/2018/04/4-2018-03-10-20.35.27-e1524795806279-600x420.jpg 600w, https://www.allatsea.net/wp-content/uploads/2018/04/4-2018-03-10-20.35.27-e1524795806279-1024x717.jpg 1024w, https://www.allatsea.net/wp-content/uploads/2018/04/4-2018-03-10-20.35.27-e1524795806279.jpg 1210w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption class="wp-caption-text">Taylor Hasson and Steve Hardee qualified for the 2018 Youth Sailing World Championships in Texas</figcaption></figure>
<p>“When you look at them (the Corsair Sprint 750 sailed by the BVI’s Eddie Brockbank and Corsair F-31 driven by Scott Johnston) at the dock they are concerning. When you look at them in motion they are scary. A big lead in multi-racing means very little. Ultimately, crew chemistry, boat preparation and constructive panic were our secrets to success,” says San Martin.</p>
<p>Nearly 20 dinghies competed in the St. Croix International Regatta in-shore event. These included Optimists and, for the first time, 29ers. In fact, this regatta was the qualifier to choose USVI teams to attend the 2018 Youth Sailing World Championships in Texas, USA. Taylor Hasson and Steve Hardee qualified for the boys, and Kate and Lucy Klempen for the girls.</p>
<figure id="attachment_160026" style="width: 600px" class="wp-caption aligncenter"><img data-attachment-id="160026" data-permalink="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/2-dsc_5577/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2018/04/2-DSC_5577-e1524795843418.jpg" data-orig-size="1390,820" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2-DSC_5577" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2018/04/2-DSC_5577-e1524795843418-600x354.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2018/04/2-DSC_5577-e1524795843418-1024x604.jpg" class="size-medium wp-image-160026" src="https://www.allatsea.net/wp-content/uploads/2018/04/2-DSC_5577-e1524795843418-600x354.jpg" alt="ISV 1554 Chris Stanton 1st in Rhodes Class" width="600" height="354" srcset="https://www.allatsea.net/wp-content/uploads/2018/04/2-DSC_5577-e1524795843418-600x354.jpg 600w, https://www.allatsea.net/wp-content/uploads/2018/04/2-DSC_5577-e1524795843418-1024x604.jpg 1024w, https://www.allatsea.net/wp-content/uploads/2018/04/2-DSC_5577-e1524795843418.jpg 1390w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption class="wp-caption-text">ISV 1554 Chris Stanton 1st in Rhodes Class</figcaption></figure>
<p>“We had great conditions both days and everything just came together for us. Steven and I have worked really hard to get where we are and have raced all over the world, but we will have to work even harder to be ready for the intense competition in Texas this summer,” says Hasson.</p>
<p>Overall, the regatta went well considering many of the race boats had been on the hard since the beginning of September and some fell over in the storm.</p>
<p>“The regatta has had set backs over the years and hurricane Maria did not help,” says regatta director Karen Stanton. “We’ve decided to move our dates to the spring and hope to increase participation in the coming years.”</p>
<p>&nbsp;</p>
<p><i>Carol M. Bareuther, RD, is a St. Thomas, U.S. Virgin Islands based marine writer and registered dietitian.</i></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-160024" class="share-facebook sd-button share-icon no-text" href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-160024" class="share-pinterest sd-button share-icon no-text" href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-160024" class="share-twitter sd-button share-icon no-text" href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-160024" class="share-google-plus-1 sd-button share-icon no-text" href="https://www.allatsea.net/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div id="wdca_ads_root"><div class="wdca_ad_item wdca_not_placed wdca_custom_ad ">
<div class="wdca_stars"></div>
<h4> <a href="#" target="_blank"><span class="wdca_title"></span></a>
</h4>
<div class="wdca_ad_body_full">
<p style="text-align: center;"><span style="color: #999999;">ADVERTISEMENT</span></p>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="d0048e28acfa355d3e3f70ba-"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9585000347357330" data-ad-slot="4815009353" data-ad-format="auto"></ins>
<script type="d0048e28acfa355d3e3f70ba-">
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p class="wdca_footer"></p></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-110032104-160024-5b06ba5b1f7e2' data-src='https://widgets.wp.com/likes/#blog_id=110032104&amp;post_id=160024&amp;origin=www.allatsea.net&amp;obj_id=110032104-160024-5b06ba5b1f7e2' data-name='like-post-frame-110032104-160024-5b06ba5b1f7e2'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div>
</div>
<div class="share-post">
<span class="share-text">Share</span>
<script type="d0048e28acfa355d3e3f70ba-">
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 	'fbjssdk' );
		load('https://apis.google.com/js/plusone.js', 		'gplus1js');
		load('//platform.twitter.com/widgets.js', 			'tweetjs' );
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
<ul class="normal-social">
<li>
<div class="fb-like" data-href="https://wp.me/p7rGnm-FD2" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
</li>
<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://wp.me/p7rGnm-FD2" data-text="Hurricanes Couldn’t Stop The 25th Saint Croix International Regatta" data-via="allatseacarib" data-lang="en">tweet</a></li>
<li style="width:80px;"><div class="g-plusone" data-size="medium" data-href="https://wp.me/p7rGnm-FD2"></div></li>
<li><script src="https://platform.linkedin.com/in.js" type="d0048e28acfa355d3e3f70ba-text/javascript"></script><script type="IN/Share" data-url="https://wp.me/p7rGnm-FD2" data-counter="right"></script></li>
</ul>
<div class="clear"></div>
</div>  <div class="clear"></div>
</div>
<script type="application/ld+json">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</script>
</article>
<p class="post-tag">Tags <a href="https://www.allatsea.net/tag/st-croix-international-regatta/" rel="tag">St. Croix International Regatta</a></p>
<div class="post-navigation">
<div class="post-previous"><a href="https://www.allatsea.net/supply-demand-caribbean-art-shopping-local/" rel="prev"><span>Previous</span> Supply and Demand: The Caribbean Art of Shopping Local</a></div>
<div class="post-next"><a href="https://www.allatsea.net/florida-students-create-robots-solve-underwater-challenges/" rel="next"><span>Next</span> Florida Students Create Robots to Solve Underwater Challenges</a></div>
</div>
<section id="related_posts">
<div class="block-head">
<h3>Related Articles</h3><div class="stripe-line"></div>
</div>
<div class="post-listing">
<div class="related-item">
<div class="post-thumbnail">
<a href="https://www.allatsea.net/saint-croix-international-regatta-back/">
<img width="310" height="165" src="https://www.allatsea.net/wp-content/uploads/2018/02/2-Dock-Good-e1519573584463-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" data-attachment-id="159550" data-permalink="https://www.allatsea.net/saint-croix-international-regatta-back/2-dock-good/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2018/02/2-Dock-Good-e1519573584463.jpg" data-orig-size="343,186" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2-Dock-Good" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2018/02/2-Dock-Good-e1519573584463.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2018/02/2-Dock-Good-e1519573584463.jpg" /> <span class="fa overlay-icon"></span>
</a>
</div>
<h3><a href="https://www.allatsea.net/saint-croix-international-regatta-back/" rel="bookmark">Saint Croix International Regatta is back!</a></h3>
<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>February 28, 2018</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://www.allatsea.net/saint-croix-yacht-club-international-regatta-postponed-march/">
<img width="310" height="165" src="https://www.allatsea.net/wp-content/uploads/2014/12/Lead-2014-St-Croix-International-by-Trish-Rhodes-399-e1419727795923-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Stan Joines, winner of Non-Spinnaker and his weight in rum, had an all youth crew. Photo: Trish Rhodes" data-attachment-id="21041" data-permalink="https://www.allatsea.net/st-croix-international-regatta-2/lead-2014-st-croix-international-by-trish-rhodes-399/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2014/12/Lead-2014-St-Croix-International-by-Trish-Rhodes-399-e1419727795923.jpg" data-orig-size="926,632" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Lead-2014-St-Croix-International-by-Trish-Rhodes-399" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2014/12/Lead-2014-St-Croix-International-by-Trish-Rhodes-399-e1419727795923-300x205.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2014/12/Lead-2014-St-Croix-International-by-Trish-Rhodes-399-e1419727795923.jpg" /> <span class="fa overlay-icon"></span>
</a>
</div>
<h3><a href="https://www.allatsea.net/saint-croix-yacht-club-international-regatta-postponed-march/" rel="bookmark">Saint Croix Yacht Club International Regatta Postponed Until March</a></h3>
<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 29, 2017</span></p>
</div>
<div class="related-item tie_thumb">
<div class="post-thumbnail">
<a href="https://www.allatsea.net/caribbean-regatta-preview-april-to-december-2017/">
<img width="310" height="165" src="https://www.allatsea.net/wp-content/uploads/2017/03/Lead-Les-Voiles-de-St.-Barths-bandeau-e1490670273700-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Caribbean Regattas" data-attachment-id="32461" data-permalink="https://www.allatsea.net/caribbean-regatta-preview-april-to-december-2017/lead-les-voiles-de-st-barths-bandeau/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2017/03/Lead-Les-Voiles-de-St.-Barths-bandeau-e1490670273700.jpg" data-orig-size="1311,802" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;@christophe_jouany&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Lead-Les-Voiles-de-St.-Barths-bandeau" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2017/03/Lead-Les-Voiles-de-St.-Barths-bandeau-e1490670273700-600x367.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2017/03/Lead-Les-Voiles-de-St.-Barths-bandeau-e1490670273700-1024x626.jpg" /> <span class="fa overlay-icon"></span>
</a>
</div>
<h3><a href="https://www.allatsea.net/caribbean-regatta-preview-april-to-december-2017/" rel="bookmark">Preview of Caribbean Regattas: April to December 2017</a></h3>
<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>April 4, 2017</span></p>
</div>
<div class="clear"></div>
</div>
</section>
<section id="check-also-box" class="post-listing check-also-right">
<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>
<div class="block-head">
<h3>Check Also</h3>
</div>
<div class="check-also-post">
<div class="post-thumbnail">
<a href="https://www.allatsea.net/day-life-regatta-volunteer/">
<img width="310" height="165" src="https://www.allatsea.net/wp-content/uploads/2018/03/Lead-Photo-by-Tim-Wright-courtesy-of-Grenada-Sailing-Week-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Regatta manager Karen (center) receives a ‘Thank You’ prize from Rosie Burr for all her hard work. Photo: Tim Wright / courtesy of Grenada Sailing Week" data-attachment-id="159809" data-permalink="https://www.allatsea.net/day-life-regatta-volunteer/lead-photo-by-tim-wright-courtesy-of-grenada-sailing-week/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2018/03/Lead-Photo-by-Tim-Wright-courtesy-of-Grenada-Sailing-Week.jpg" data-orig-size="1687,1125" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Tim Wright&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Lead-Photo-by-Tim-Wright-courtesy-of-Grenada-Sailing-Week" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2018/03/Lead-Photo-by-Tim-Wright-courtesy-of-Grenada-Sailing-Week-600x400.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2018/03/Lead-Photo-by-Tim-Wright-courtesy-of-Grenada-Sailing-Week-1024x683.jpg" /> <span class="fa overlay-icon"></span>
</a>
</div>
<h2 class="post-title"><a href="https://www.allatsea.net/day-life-regatta-volunteer/" rel="bookmark">A Day in the Life of a Regatta Volunteer</a></h2>
<p>It’s the second race day of the regatta. I crawl out of bed at an &hellip;</p>
</div>
</section>
<div id="comments">
<div class="clear"></div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/hurricanes-couldnt-stop-25th-saint-croix-international-regatta/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=110032104&#038;postid=160024&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=6.1.1&#038;sig=2a7a8418f5d424d2fd2a4fe96c196d0ac433eb5c#parent=https%3A%2F%2Fwww.allatsea.net%2Fhurricanes-couldnt-stop-25th-saint-croix-international-regatta%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script type="d0048e28acfa355d3e3f70ba-">
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
<aside id="sidebar">
<div class="theiaStickySidebar">
<div id="media_image-2" class="widget widget_media_image"><div class="widget-top"><h4>Download the Latest Edition</h4><div class="stripe-line"></div></div>
<div class="widget-container"><a href="https://www.allatsea.net/download-all-at-sea/"><img width="180" height="230" src="https://www.allatsea.net/wp-content/uploads/2018/05/all-at-sea-caribbean-0518-180.jpg" class="image wp-image-160099  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" data-attachment-id="160099" data-permalink="https://www.allatsea.net/download-all-at-sea/all-at-sea-caribbean-0518-180/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2018/05/all-at-sea-caribbean-0518-180.jpg" data-orig-size="180,230" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="all-at-sea-caribbean-0518-180" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2018/05/all-at-sea-caribbean-0518-180.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2018/05/all-at-sea-caribbean-0518-180.jpg" /></a></div></div><div id="ads300_600-widget-4" class="widget e3lan e3lan300_600-widget"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
<div class="widget-container"> <div class="e3lan-widget-content e3lan300-600">
<div class="e3lan-cell">

<div id='div-gpt-ad-1400683834746-1' style='width:300px; height:600px;'>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1400683834746-1'); });
</script>
</div>
</div>
</div>
</div></div> </div>
</aside> <div class="clear"></div>
</div>
<footer id="theme-footer">
<div id="footer-widget-area" class="footer-4c">
<div id="footer-first" class="footer-widgets-box">
<div id="text-41" class="footer-widget widget_text"><div class="footer-widget-top"><h4>Search</h4></div>
<div class="footer-widget-container"> <div class="textwidget"><p><script type="d0048e28acfa355d3e3f70ba-">
  (function() {
    var cx = '017924919526698187451:ay6kfu2gska';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script><br />
<gcse:searchbox-only></gcse:searchbox-only></p>
</div>
</div></div><div id="nav_menu-5" class="footer-widget widget_nav_menu"><div class="footer-widget-top"><h4>All At Sea &#8211; CARIBBEAN</h4></div>
<div class="footer-widget-container"><div class="menu-footer-utilities-caribbean-container"><ul id="menu-footer-utilities-caribbean" class="menu"><li id="menu-item-14193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14193"><a href="https://www.allatsea.net/all-at-sea-advertising/">Advertising &#8211; All At Sea &#8211; Caribbean</a></li>
<li id="menu-item-5135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5135"><a href="http://www.allatsea.net/caribbean/classified_list/">Classifieds</a></li>
<li id="menu-item-14192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14192"><a href="https://www.allatsea.net/download-all-at-sea/">Download ALL AT SEA</a></li>
<li id="menu-item-14200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14200"><a href="https://www.allatsea.net/subscriptions/">Subscribe to All At Sea Caribbean</a></li>
</ul></div></div></div><div id="nav_menu-7" class="footer-widget widget_nav_menu"><div class="footer-widget-top"><h4>Utilities</h4></div>
<div class="footer-widget-container"><div class="menu-utilities-container"><ul id="menu-utilities" class="menu"><li id="menu-item-14327" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14327"><a href="https://www.allatsea.net/aboutus/">About Us</a></li>
<li id="menu-item-14326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14326"><a href="https://www.allatsea.net/contact-us/">Contact Us</a></li>
<li id="menu-item-14324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14324"><a href="https://www.allatsea.net/all-at-sea-sitemap-page/">Sitemap</a></li>
<li id="menu-item-14325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14325"><a href="https://www.allatsea.net/all-at-sea-authors-list/">Authors</a></li>
</ul></div></div></div> </div>
<div id="footer-second" class="footer-widgets-box">
<div id="comments_avatar-widget-2" class="footer-widget comments-avatar"><div class="footer-widget-top"><h4>Recent Comments </h4></div>
<div class="footer-widget-container"> <ul>
<li>
<div class="post-thumbnail" style="width:55px">
<img alt='' src='https://secure.gravatar.com/avatar/47e74ccc82fcf10a32b3f0da978e1d3c?s=55&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/47e74ccc82fcf10a32b3f0da978e1d3c?s=110&#038;d=mm&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' /> </div>
<a href="https://www.allatsea.net/sean-paton-shares-thoughts-sea/#comment-102765">
Steve Kirkby: Wonderful article Sean. I spent 11 years on the ocean, but not, unfortunately un... </a>
</li>
<li>
<div class="post-thumbnail" style="width:55px">
<img alt='' src='https://secure.gravatar.com/avatar/05dfe3a104d569bd3bfa8b0e9a301b1a?s=55&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/05dfe3a104d569bd3bfa8b0e9a301b1a?s=110&#038;d=mm&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' /> </div>
<a href="https://www.allatsea.net/motor-sailing-sad-tales/#comment-102739">
Richard Elder: Hi Fatty, Back in the day I was living on board at the guest dock in Seattle, tr... </a>
</li>
<li>
<div class="post-thumbnail" style="width:55px">
<img alt='' src='https://secure.gravatar.com/avatar/c5ec2e328876e2ff95e04acba0357627?s=55&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/c5ec2e328876e2ff95e04acba0357627?s=110&#038;d=mm&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' /> </div>
<a href="https://www.allatsea.net/install-new-trampoline-multihull/#comment-102726">
Bradford Johanson: From the pictures I cannot understnd how the rope ede is connected to the nettin... </a>
</li>
<li>
<div class="post-thumbnail" style="width:55px">
<img alt='' src='https://secure.gravatar.com/avatar/5a6d1d68ff26b3433b5161fff2f81bd8?s=55&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/5a6d1d68ff26b3433b5161fff2f81bd8?s=110&#038;d=mm&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' /> </div>
<a href="https://www.allatsea.net/install-new-trampoline-multihull/#comment-102723">
Grant "Reality": Manta Catamarans have the best tramps for durability, comfort and function.... </a>
</li>
<li>
<div class="post-thumbnail" style="width:55px">
<img alt='' src='https://secure.gravatar.com/avatar/10bc2919d0db0a1a80bf445d7c2ccafc?s=55&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/10bc2919d0db0a1a80bf445d7c2ccafc?s=110&#038;d=mm&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' /> </div>
<a href="https://www.allatsea.net/the-latest-in-epirbs/#comment-102664">
Steven Marshall: Really. what percentage of boaters do you know to have this type of equipment on... </a>
</li>
</ul>
</div></div> </div>
<div id="footer-third" class="footer-widgets-box">
<div id="posts-list-widget-3" class="footer-widget posts-list"><div class="footer-widget-top"><h4>Talkative Posts </h4></div>
<div class="footer-widget-container"> <ul>
 <li>
<div class="post-thumbnail">
<a href="https://www.allatsea.net/saying/" title="Saying “NO!”" rel="bookmark"><img width="110" height="75" src="https://www.allatsea.net/wp-content/uploads/2014/02/Fat-mast-wind-speed-7-e1392853392869-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" data-attachment-id="16963" data-permalink="https://www.allatsea.net/saying/fat-mast-wind-speed-7/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2014/02/Fat-mast-wind-speed-7-e1392853392869.jpg" data-orig-size="431,711" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fat-mast-wind-speed-(7)" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2014/02/Fat-mast-wind-speed-7-e1392853392869-182x300.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2014/02/Fat-mast-wind-speed-7-e1392853392869.jpg" /><span class="fa overlay-icon"></span></a>
</div>
<h3><a href="https://www.allatsea.net/saying/">Saying “NO!”</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>April 4, 2014</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/saying/#comments">25</a></span>
</li>
<li class="tie_thumb">
<div class="post-thumbnail">
<a href="https://www.allatsea.net/anchoring-a-boat-the-ultimate-guide/" title="Anchoring a Boat: The Ultimate Guide" rel="bookmark"><img width="110" height="75" src="https://www.allatsea.net/wp-content/uploads/2014/05/1_IMG_1305-e1401231332327-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Ganesh’s Rocna anchor fits like a glove" data-attachment-id="18274" data-permalink="https://www.allatsea.net/anchoring-a-boat-the-ultimate-guide/1_img_1305/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2014/05/1_IMG_1305-e1401231332327.jpg" data-orig-size="944,680" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="1_IMG_1305" data-image-description="" data-medium-file="https://www.allatsea.net/wp-content/uploads/2014/05/1_IMG_1305-e1401231332327-300x216.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2014/05/1_IMG_1305-e1401231332327.jpg" /><span class="fa overlay-icon"></span></a>
</div>
<h3><a href="https://www.allatsea.net/anchoring-a-boat-the-ultimate-guide/">Anchoring a Boat: The Ultimate Guide</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>June 10, 2014</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/anchoring-a-boat-the-ultimate-guide/#comments">13</a></span>
</li>
<li>
<h3><a href="https://www.allatsea.net/so-you-wanna-buy-a-boat-part-i-how-will-i-use-my-boat/">So you Wanna&#8217; Buy a Boat? Why do you Want a Boat?</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>October 1, 2005</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/so-you-wanna-buy-a-boat-part-i-how-will-i-use-my-boat/#comments">12</a></span>
</li>
<li>
<h3><a href="https://www.allatsea.net/so-you-wanna-buy-a-boat-ii-what-do-i-really-want/">What Kind of Boat do you WANT and NEED?</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>November 1, 2005</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/so-you-wanna-buy-a-boat-ii-what-do-i-really-want/#comments">11</a></span>
</li>
<li class="tie_thumb">
<div class="post-thumbnail">
<a href="https://www.allatsea.net/vulnerability-sharks-commercial-fishing/" title="Vulnerability of Sharks in Commercial Fishing" rel="bookmark"><img width="110" height="75" src="https://www.allatsea.net/wp-content/uploads/2014/07/shark-collateral-e1406634733265-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="A new study that examined the survival rates of 12 different shark species when captured as unintentional bycatch in commercial longline fishing operations found large differences in survival rates across the 12 species, with bigeye thresher, dusky, and scalloped hammerhead being the most vulnerable. Image courtesy of Frank Gibson - Sharktagging.com" data-attachment-id="18942" data-permalink="https://www.allatsea.net/vulnerability-sharks-commercial-fishing/shark-collateral/" data-orig-file="https://www.allatsea.net/wp-content/uploads/2014/07/shark-collateral-e1406634733265.jpg" data-orig-size="775,376" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="shark-collateral" data-image-description="&lt;p&gt;A new study that examined the survival rates of 12 different shark species when captured as unintentional bycatch in commercial longline fishing operations found large differences in survival rates across the 12 species, with bigeye thresher, dusky, and scalloped hammerhead being the most vulnerable.  Image courtesy of Frank Gibson &#8211; Sharktagging.com&lt;/p&gt;
" data-medium-file="https://www.allatsea.net/wp-content/uploads/2014/07/shark-collateral-e1406634733265-300x146.jpg" data-large-file="https://www.allatsea.net/wp-content/uploads/2014/07/shark-collateral-e1406634733265.jpg" /><span class="fa overlay-icon"></span></a>
</div>
<h3><a href="https://www.allatsea.net/vulnerability-sharks-commercial-fishing/">Vulnerability of Sharks in Commercial Fishing</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>July 22, 2014</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/vulnerability-sharks-commercial-fishing/#comments">10</a></span>
</li>
<li>
<h3><a href="https://www.allatsea.net/new-biocide-free-bottom-paint-launched-by-interlux/">New Biocide Free Bottom Paint Launched by Interlux</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>April 1, 2009</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/new-biocide-free-bottom-paint-launched-by-interlux/#comments">10</a></span>
</li>
<li>
<h3><a href="https://www.allatsea.net/boat-buying-guide-survey-and-sea-trial/">Boat Buying Guide: Survey and Sea Trial</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>September 1, 2006</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/boat-buying-guide-survey-and-sea-trial/#comments">9</a></span>
</li>
<li>
<h3><a href="https://www.allatsea.net/boat-buying-guide-part-iii-the-budget-insurance/">Top Five Buying Tips for Boat Insurance</a></h3>
<span class="tie-date"><i class="fa fa-clock-o"></i>December 1, 2005</span> <span class="post-comments post-comments-widget"><i class="fa fa-comments"></i><a href="https://www.allatsea.net/boat-buying-guide-part-iii-the-budget-insurance/#comments">9</a></span>
</li>
</ul>
<div class="clear"></div>
</div></div> </div>
</div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
<div class="footer-bottom">
<div class="container">
<div class="alignright">
</div>
<div class="social-icons">
<a class="ttip-none" title="Rss" href="https://feeds.feedburner.com/allatsea/iHcq" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/+AllatseaNet" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/ALLATSEACaribbean" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://www.twitter.com/allatseacarib" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Pinterest" href="https://pinterest.com/allatseamag/" target="_blank"><i class="fa fa-pinterest"></i></a>
</div>
<div class="alignleft">
Kennan Holdings LLC DBA All At Sea © Copyright 1993-2017, All Rights Reserved </div>
<div class="clear"></div>
</div>
</div>
</div>
</div>
</div>
<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<div id="mailchimp-top-bar" class="mctb mctb-sticky mctb-position-top mctb-medium">

<div class="mctb-bar" style="display: none">
<form method="post">
<label class="mctb-label" for="mailchimp-top-bar__email">Sign-up now - So Caribbean you can almost taste the rum!</label>
<input type="email" name="email" placeholder="Your email address.." class="mctb-email" required id="mailchimp-top-bar__email" />
<input type="text" name="email_confirm" placeholder="Confirm your email" value="" autocomplete="off" tabindex="-1" class="mctb-email-confirm" />
<input type="submit" value="Subscribe" class="mctb-button" />
<input type="hidden" name="_mctb" value="1" />
<input type="hidden" name="_mctb_no_js" value="1" />
<input type="hidden" name="_mctb_timestamp" value="1527167579" />
</form>
</div>

</div>
<script type="d0048e28acfa355d3e3f70ba-">
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<div style="display:none">
<div class="grofile-hash-map-47e74ccc82fcf10a32b3f0da978e1d3c">
</div>
<div class="grofile-hash-map-05dfe3a104d569bd3bfa8b0e9a301b1a">
</div>
<div class="grofile-hash-map-c5ec2e328876e2ff95e04acba0357627">
</div>
<div class="grofile-hash-map-5a6d1d68ff26b3433b5161fff2f81bd8">
</div>
<div class="grofile-hash-map-10bc2919d0db0a1a80bf445d7c2ccafc">
</div>
</div>

<script type="d0048e28acfa355d3e3f70ba-">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65281-1', 'auto');
  ga('send', 'pageview');

</script>

<div id="reading-position-indicator"></div><script type="d0048e28acfa355d3e3f70ba-"> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script> <script type="d0048e28acfa355d3e3f70ba-text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.allatsea.net\/hurricanes-couldnt-stop-25th-saint-croix-international-regatta\/":160024};
	</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">var _wdca={"first_ad":0,"count":0,"selector":">p","predefined":{"before":0,"middle":1,"after":0,"ignore_other":0,"ignore_requirement":3},"ga":{"enabled":true,"category":"In Post Ads","label":"Default"},"non_indexing_wrapper":false,"pfx":"wdca_","dynamic_styles":false,"ajax_url":"https:\/\/www.allatsea.net\/wp-admin\/admin-ajax.php"};</script><!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.allatsea.net/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='wdca-css' href='https://www.allatsea.net/wp-content/plugins/custom-ads/css/wdca.css' type='text/css' media='all' />
<link rel='stylesheet' id='wdca-theme-css' href='https://www.allatsea.net/wp-content/plugins/custom-ads/css/wdca-default.css' type='text/css' media='all' />
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.allatsea.net\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.allatsea.net\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_8d424aa59bbcc14dc20525ff40f95826","fragment_name":"wc_fragments_8d424aa59bbcc14dc20525ff40f95826"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://secure.gravatar.com/js/gprofiles.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var mctb = {"cookieLength":"90","icons":{"hide":"&#x25B2;","show":"&#x25BC;"},"position":"top","state":{"submitted":false,"success":false}};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/mailchimp-top-bar/assets/js/script.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-includes/js/comment-reply.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-includes/js/wp-embed.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/themes/sahifa/js/search.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/spin.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.allatsea.net\/wp-admin\/admin-ajax.php","nonce":"14060357f2","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.allatsea.net\/wp-login.php?redirect_to=https%3A%2F%2Fwww.allatsea.net%2Fhurricanes-couldnt-stop-25th-saint-croix-international-regatta%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/postmessage.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js'></script>
<script async="async" type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/akismet/_inc/form.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://www.allatsea.net/wp-content/plugins/custom-ads/js/wdca.js'></script>
<iframe src='https://widgets.wp.com/likes/master.html?ver=201821#ver=201821' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110032104&postid=160024&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.1.1&sig=2a7a8418f5d424d2fd2a4fe96c196d0ac433eb5c#parent=https%3A%2F%2Fwww.allatsea.net%2Fhurricanes-couldnt-stop-25th-saint-croix-international-regatta%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110032104&postid=160024&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.1.1&sig=2a7a8418f5d424d2fd2a4fe96c196d0ac433eb5c#parent=https%3A%2F%2Fwww.allatsea.net%2Fhurricanes-couldnt-stop-25th-saint-croix-international-regatta%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript" src='https://stats.wp.com/e-201821.js' async='async' defer='defer'></script>
<script type="d0048e28acfa355d3e3f70ba-text/javascript">
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1.1',blog:'110032104',post:'160024',tz:'0',srv:'www.allatsea.net'} ]);
	_stq.push([ 'clickTrackerInit', '110032104', '160024' ]);
</script>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/5ad2c803/cloudflare-static/rocket-loader.min.js" data-cf-nonce="d0048e28acfa355d3e3f70ba-" defer=""></script></body>
</html>